Ik wilde vandaag een van blogs een wat gelikter uiterlijk geven. Om dit te doen leek het me handig om eerst de WordPress versie waar dit blog op draait bij te werken. Het draait namelijk op een wat verlopen versie volgens het aloude devies: “If it ain’t broke, don’t fix it.” Nu leek me dat het tijd werd dit devies eens te laten voor wat het is en even een zaterdagmiddag wat aan te klooien met de nieuwe mogelijkheden van WP 2.6.5

Leuk plan maar het bleek toch te ambitieus voor mijn enigszins beneveld weekend-hoofd (het was vrijdagavond enne, nou ja, je weet wel…). Na het downloaden van de laatste versie van Wo

rdpress van de WordPress site eerst de benodigde gegevens ingevuld in het config bestandje. Aangezien Ervaring zelfs door een duf hoofd heen op de deur van Achterdocht beukt had ik voor de zekerheid ook maar een kopie gemaakt van de oude blog map.

De nieuwe WP map was snel ge-upload. Ik verwachtte geen instant succes maar ook geen instant rampen. De verwachting was een soort tussen stand waarbij er met nog enig sleutelen al snel weer een acceptabel blog zou draaien. Helaas ” CGI error: The specified CGI application misbehaved…” was het enige wat de browser mij wist te vertellen na het intikken van de blog URL.

Nou komt deze melding mij niet onbekend voor. Dat heb ik al eens eerder gehad bij een WP upgrade. Hoe moest dat ook alweer? Oh ja, ergens moest je dan een bestandje vervangen. Had met een incompatibiliteit te maken tussen een Windows server en WordPress. Goh, dacht dat ze dat toch inmiddels wel zouden hebben opgelost. Maar goed, vol goede hoop het WordPress.org forum op en ja hoor, na even zoeken al gevonden. Het wp-db.php bestandje moet gepatched worden, nu herinnerde ik het me ook weer. Zo gezegd, zo gedaan.

Hoopvol de browser weer richting de goede URL gestuurd. Noppes. En dan bedoel ik echt noppes. Een blank scherm met heel droog links onderin de Firefox balk “Done”. Ja, wat “Done”? Hoebedoelu “Done”? *Zucht*.

Weer terug naar het forum. Oh, al deze tips over de wp-db.php patch gaan over WP driepuntzoveel. Dit is WP zespuntzoveel. Ik lees zelfs dat dit probleem bij WP vijfpuntzoveel opgelost is. Blijkbaar hebben ze dat nog niet tegen mijn host gezegd. De Windows server die daar draait geeft nog steeds fijn de oude vertrouwde error. Toch fijn als een server zo consistent is. Je zou er bijna op gaan vertrouwen.

Na nog wat ge-download en ge-upload; getik en gezoek; geef ik het op. Verslagen, niet voor de eerste keer, door een Windows server en open source software die daar op moet draaien. In mijn systeembeheer dagen gaf ik het natuurlijk niet zo makkelijk op. Maar ja, toen kon ik de lease-auto pakken en de server hoogst persoonlijk even de waarheid gaan zeggen en dreigen met een degradatie tot nietige spiegelschijf van de in een weekend nieuw te bouwen Linux/UNIX server. Een dreigement wat ik – zonder de baas daarover al teveel wijzer te maken – zondermeer uitvoerde. Helaas, in dit geval ben ik gedoemd tot een langdurige email uitwisseling met een hosting-bedrijf zonder dat ik daarmee het beoogde doel (een ?NIX server) zal bereiken.

Waar leidt dit stukje naar toe? Wat is de clou? Je wilt natuurlijk een moraal, dat is wel het minste. Nou de moraal van dit verhaal is – en ik zou het vetgedrukt op m’n monitor moeten plakken –  “If it ain’t broke, don’t fix it.”

ps. Als je ideeën hebt over de stommiteit die ik begaan heb waardoor de boel niet draait dan houdt ik me natuurlijk aanbevolen voor tips.

0 Shares:
5 comments
  1. Ik weet niet of dit instant je probleem oplost, maar WordPress heeft een plugin waarmee je heel gemakkelijk naar de nieuwste versie van WP kunt upgraden. Ik stond ook altijd heel wantrouwend tegenover het upgraden van WordPress, maar sinds deze plugin ben ik altijd helemaal up to date en behalve een paar muisklikken hoef je zelf niet veel te doen.

    http://wordpress.org/extend/plugins/wordpress-aut

  2. Hoi Sanne,

    Bedankt. Ik ga er naar kijken. Ik hoop dat de plugin ook werkt voor (hele) oude wordpress versies. Ik meld me weer met een resultaten rapport :-)

    Henk

  3. @Sanne: Bedankt nogmaals voor de automatische WP upgrade plugin. Heb het geprobeerd op een van mijn minder actieve blogs en het werkt als een zonnetje. Ga nu mijn belangrijkere blogs doen. Blijf mijn vingers EN tenen gekruisd houden maar het lijkt goed te werken :)

Comments are closed.

Dit artikel is 3.246 keer gelezen